Possible Google Gmail sending/receiving delays 3/10
Incident Report for New Haven Unified School District
Resolved
We believe this incident has been fully resolved.
Posted Mar 10, 2021 - 19:04 PST
Monitoring
A fix is in place and we're seeing normal email traffic restored. Will continue to monitor for a while to verify.
Posted Mar 10, 2021 - 17:01 PST
Investigating
We are getting multiple reports of trouble sending or receiving Gmail from/to NHUSD Gmail accounts (only). We are not seeing any indications that mail is failing (no error messages) but very delayed sending and receiving from one NHUSD person to another NHUSD person. Google Support has not indicate an issue yet - but we are investigating at this time.
Posted Mar 10, 2021 - 09:47 PST
This incident affected: G Suite For Education (Google Apps Gmail).