Reports of problems accessing Google Drive/Docs/Sheets/Slides
Incident Report for New Haven Unified School District
Resolved
Google reports this issue has been resolved as of 10:46 AM.
Posted Jan 27, 2020 - 11:22 PST
Identified
Google is investigating this outage and has reported: "We're investigating reports of an issue with Google Drive/Docs/Sheets/Slides. We will provide more information shortly. The affected users are unable to access Google Drive."
Posted Jan 27, 2020 - 10:51 PST
This incident affected: G Suite For Education (Google Apps Drive, Google Apps Docs, Google Apps Sheets, Google Apps Slides).