ESCAPE Outage 9/11/19
Incident Report for New Haven Unified School District
Resolved
Trouble with ESCAPE has been cleared and it is back up and working normally. Thank you for your patience!
Posted Sep 11, 2019 - 08:57 PDT
Identified
ESCAPE (Finance and Payroll System managed by our Alameda County Office of Education) is currently down. They are working on the problem and will update us when they have more info to share.
Posted Sep 11, 2019 - 08:20 PDT
This incident affected: Other District Systems.