Clever login issues for students and staff 1/14
Incident Report for New Haven Unified School District
Resolved
This issue is resolved.
Posted Jan 14, 2021 - 12:04 PST
Monitoring
Clever Support is still working on the overall issue, but we're being told that issues for us should be cleared now. Will continue to monitor.
Posted Jan 14, 2021 - 10:56 PST
Identified
Clever is working to resolve some system problems that are affecting student and staff logins (logins to Chromebooks included).
This is their status page for up-to-date info: https://status.clever.com/
Posted Jan 14, 2021 - 08:58 PST
This incident affected: Clever (Clever Single Sign-On).