Google Calendar Problems 06/18
Incident Report for New Haven Unified School District
Resolved
Issue with Google Calendar has been resolved by Google Support today at 10:13 AM.
Posted Jun 18, 2019 - 10:41 PDT
Investigating
We are receiving reports of trouble with Google Calendar. This is an issue on Google's side and they are currently investigating. Feel free to watch here for status updates: https://www.google.com/appsstatus#hl=en&v=status
Posted Jun 18, 2019 - 08:01 PDT
This incident affected: G Suite For Education (Google Apps Calendar).