Major Google Outage, affecting sign-in to Chromebooks and Google Chrome and Clever
Incident Report for New Haven Unified School District
Resolved
We have been informed that this has been resolved. Closing this incident.
Posted Dec 13, 2022 - 16:36 PST
Monitoring
We are still waiting for official confirmation from Google Support, but we are now seeing successful Chromebook logins as of 1:30PM this afternoon. Other districts are also reporting that this problem looks cleared. We will wait for further info from Google Support and continue to monitor.
Posted Dec 13, 2022 - 13:42 PST
Identified
We are receiving NUMEROUS reports of getting redirected back to the login screen at login for students and staff on Chromebooks. This is a widespread issue affecting (as far as I can see) ALL school districts at this time. We are contacting Google Support and hoping for more information soon. Login to Chromebooks, Chrome on other devices, and Clever logins are affected.
Posted Dec 13, 2022 - 11:40 PST
This incident affected: G Suite For Education (Google Apps Gmail, Google Apps Drive) and Other District Systems.