Partial Google Outage April 12, 2021
Incident Report for New Haven Unified School District
Resolved
According to Google Support, all problems are resolved:
"The problem with Google Drive has been resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Google, and we are making continuous improvements to make our systems better.

Please try reloading the page, or coming back to it in a few minutes."
Posted Apr 12, 2021 - 09:37 PDT
Update
Update from Google Support:
"Google Drive service (and other services) has already been restored for some users, and we expect a resolution for all users in the near future. Please note this time frame is an estimate and may change. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Please try reloading the page, or coming back to it in a few minutes."
Posted Apr 12, 2021 - 09:06 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 12, 2021 - 09:05 PDT
Identified
Google has reported Google Drive, Docs, Sheets, Slides, and Classroom are affected by the following problem, and they are working on it:
"We're investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Affected user are unable to create new documents."
Posted Apr 12, 2021 - 08:08 PDT
This incident affected: G Suite For Education (Google Apps Drive, Google Apps Docs, Google Apps Classroom, Google Apps Sheets, Google Apps Slides).