District wide: Partial Clever Outage for students and teachers, repairs in progress

Incident Report for New Haven Unified School District

Resolved

This has been resolved!
Posted Oct 15, 2025 - 13:02 PDT

Identified

Clever Support is reporting: "Clever is experiencing an issue with some reports of the Portal not loading for Students and Teachers on the west-coast. We are investigating the issue and will provide regular status updates."
Here are the latest updates: https://status.clever.com/
Posted Oct 15, 2025 - 08:40 PDT
This incident affected: Clever (Clever Single Sign-On).