Alert: District-wide internet & phones outage
Incident Report for New Haven Unified School District
Resolved
This issue is resolved.
Posted Mar 14, 2023 - 14:55 PDT
Monitoring
Power has been restored and we will continue to monitor for 1 hour to ensure all systems are back online.
Posted Mar 14, 2023 - 13:24 PDT
Identified
The district office (ESC) is currently on backup power due to a PGE outage; internet and phones will be down shortly unless the power comes back up shortly. We will update again as soon as we have more info.
Posted Mar 14, 2023 - 12:17 PDT
This incident affected: Internet/Network Connectivity, Jive Phones, and Other District Systems.