PWM Password Management Site is working with an expired certificate
Incident Report for New Haven Unified School District
Resolved
This incident is 100% resolved and tested. Thank you for your patience.
Posted May 04, 2021 - 12:43 PDT
Identified
PWM - https://pwm.mynhusd.org:8443/pwm/

is not down, but it is working with an expired SSL certificate. It still works, and it is secure, but we are having trouble activating the new SSL certificate and this will take more time. You can continue to use it. This should be resolved on Monday 5/03.

Directions:
Go to the website at https://pwm.mynhusd.org:8443/pwm/
In Chrome, you will received a "Your connection is not private" warning page.
On the bottom left, click the "Advanced" button.
The page will expand, click "Proceed to pwm.mynhusd.org (unsafe)".
Login and use the system as you have before.
Posted May 02, 2021 - 18:06 PDT
This incident affected: Other District Systems.