Canvas outage 8/31/26 All Sites

Incident Report for New Haven Unified School District

Resolved

This issue is fully resolved.
Posted Aug 31, 2026 - 18:13 PDT

Monitoring

Canvas Support (Instructure) reports that a fix is in place and they are monitoring. We are hearing reports from staff that Canvas is working now.
Posted Aug 31, 2026 - 14:31 PDT

Identified

Canvas is down due to Canvas system problems. Please see their status page for the latest updates: https://status.instructure.com/
Posted Aug 31, 2026 - 11:47 PDT
This incident affected: Other District Systems.