Problems cleared as of 4:00 PM today. Closing this alert.
Posted Jan 30, 2026 - 16:34 PST
Monitoring
We have been told that this issue is resolved but will continue to monitor for problems for the rest of the day.
Posted Jan 30, 2026 - 13:48 PST
Update
Securly is reporting that fixes are being deployed across all their customers. We have not received an "all clear" message yet, but we are seeing a huge improvement in how our student web access is being processed. The student Chromebook experience should be close to normal at this time. Will update more when we get confirmation from Securly Support, or if we see different behavior.
Posted Jan 30, 2026 - 09:58 PST
Identified
We are seeing Securly filtering (web filter on student Chromebooks) incorrectly blocking many legitimate websites such as Canvas, IXL, Edgenuity, YouTube, more. We have reported the problem to Securly Support as an URGENT problem. We are hoping that this is resolved before start of school on Friday 1/30. Please note that this problem started after hours on Thursday night, while students may have been trying to work on homework.
Posted Jan 29, 2026 - 22:00 PST
This incident affected: Internet/Network Connectivity.