[District-Wide] Clever Outage, due to AWS web infrastructure problems 2/10/26 12:47 PST

Incident Report for New Haven Unified School District

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 17:33 PST

Monitoring

Clever Support reports all clear at 2:58 PM PST! Will continue to monitor for the rest of the day.
Posted Feb 10, 2026 - 15:30 PST

Identified

Clever is having increasingly worse problems today, and is currently down. Their most updated info is here: https://status.clever.com/
Posted Feb 10, 2026 - 13:52 PST
This incident affected: Clever (Clever District Administration Dashboard, Clever Apps Dashboard, Clever Single Sign-On).