Google Drive Down/Slow 9/08/20
Incident Report for New Haven Unified School District
Resolved
According to Google at 10:23AM today 9/8/20: The problem with Google Drive should be resolved. We apologize for the inconvenience and thank you for your patience and continued support.
Posted Sep 08, 2020 - 10:59 PDT
Identified
We are having multiple reports of Google Drive (and Google Docs stored on Drive) being slow or unusable. This is confirmed by sites on the internet such as Down Detector ( https://downdetector.com/status/google-drive/ ) but Google has not acknowledged any problem at this time. This is not a local (New Haven) problem. We will update with more information as it becomes available.
Posted Sep 08, 2020 - 09:23 PDT
This incident affected: G Suite For Education (Google Apps Drive, Google Apps Docs).