Follett Destiny (Library System) is down due to "unplanned maintenance" problems 4/20/23
Incident Report for New Haven Unified School District
Resolved
This incident is resolved. This is from their status page site:

Destiny: Maintenance Complete
The unplanned maintenance for the Follett Destiny cloud environment has been completed. As part of this maintenance, we have upgraded all hosted customers to Destiny 20.0. To learn about this new release, view our What's New document on follettcommunity.com. If you are experiencing any issues with the 20.0 upgrade, please contact Follett Destiny Technical Support.
Posted Apr 21, 2023 - 07:19 PDT
Identified
Follett Software is down with internal problems. This is from their status page site:
"Destiny: Outage
Due to unplanned maintenance, the Follett Destiny cloud environment will be inaccessible until 5:00 AM, April 21. We apologize for the inconvenience and are working to get the system available as soon as possible."

Please check their status page for more info and updates: https://status.follettsoftware.com/
Posted Apr 20, 2023 - 14:52 PDT
This incident affected: Other District Systems.