Alert: Chromebook login issues; students cannot login 8/25/23 9:15AM
Incident Report for New Haven Unified School District
Resolved
This was resolved fully by Google Support Engineers by 2:39 PM Friday 8/25.
Posted Aug 25, 2023 - 15:26 PDT
Identified
Google Support has confirmed this is a big problem affecting multiple school districts and their engineers are working to resolve this. We will update again as soon as we have more information and an ETA.
Posted Aug 25, 2023 - 10:38 PDT
Investigating
We are getting multiple reports of students getting a black screen on login to Chromebook and then being re-directed to login again, or being stuck in a loop like this and unable to login. Other school districts are also having this issue. We are currently in the queue to speak with Google Support, but we suspect this is a Google problem. We will update again as soon as we confirm and get an ETA on problem resolution.
Posted Aug 25, 2023 - 09:20 PDT
This incident affected: G Suite For Education (Google Apps Gmail) and Other District Systems.