Amazon AWS has announced that all services are back to normal. Our 3rd party vendors have confirmed. Issue is resolved.
Posted Oct 20, 2025 - 16:20 PDT
Monitoring
Amazon Web Services or AWS has become a significant backbone to many of the 3rd party web services we use today. Some of the common ones we use at NHUSD include: Clever, Canvas, Apptegy, GoToConnect, and many more. AWS had a major outage early this morning and has recovered, but is still seeing a delay in services which may effect us. Most of the 3rd party services we use (some mentioned above) have reported that they are no longer down, but may be slower than usual as systems come back to normal. If you're seeing slowness or occasional page load problems, this is most likely the cause. We will continue to monitor and will update as needed.
Posted Oct 20, 2025 - 08:55 PDT
This incident affected: Internet/Network Connectivity and Other District Systems.