Alert: Google Drive/Docs/images Problems 4/17 started at 11:43AM
Incident Report for New Haven Unified School District
Resolved
According to Google Support, this is resolved:
"The issue with Google Docs has been resolved for all affected users as of Monday, 2023-04-17 13:54 US/Pacific.
We will publish an analysis of this incident once we have completed our internal investigation.
We thank you for your patience while we worked on resolving the issue."
Posted Apr 17, 2023 - 14:26 PDT
Identified
According to Google Support: "Google Workspace customers may experience errors with editors functions (CopyDocument, CopyFromTemplate, InsertImages, etc.)". Apparently this affects Google Slides and adding images, as well as other common Google Docs and Drive features. We will keep an eye on this and update again as soon as we have more info.
Posted Apr 17, 2023 - 13:49 PDT
This incident affected: G Suite For Education (Google Apps Drive, Google Apps Docs, Google Apps Sheets, Google Apps Slides).