Learning A-Z and Raz Kids Outage 8/28/23 10:00 AM
Incident Report for New Haven Unified School District
Resolved
We have been notified that this has been resolved by the vendor. Thank you!
Posted Aug 28, 2023 - 11:26 PDT
Identified
We have been notified that Learning A-Z and Raz Kids (for Elementary schools) are currently down. We will send another notice with more information as soon as we can. Thank you!
Posted Aug 28, 2023 - 10:26 PDT
This incident affected: Other District Systems.