Canvas is currently down
Incident Report for New Haven Unified School District
Resolved
This incident has been resolved and Canvas access is restored.
Posted Nov 29, 2022 - 13:25 PST
Identified
We are working with Canvas Support (Instructure) to remedy the problem.
Posted Nov 29, 2022 - 13:06 PST
This incident affected: Other District Systems.